Back to overview
Downtime
Migration of DNS
Mar 31 at 10:31am CEST
Affected services
Changelog
Resolved
Mar 31 at 10:58am CEST
Changelogs are back up
Affected services
Changelog
Created
Mar 31 at 10:31am CEST
Changelogs will be temporarily unavailable due to a DNS migration
Affected services
Changelog