Back to overview
Downtime
Custom Changelog URL's unreachable
Jul 15 at 09:47am CEST
Affected services
Changelog
Resolved
Jul 15 at 10:41am CEST
The situation is back to normal
Affected services
Updated
Jul 15 at 09:56am CEST
The changelogs are back up but we keep monitoring the issue
Affected services
Created
Jul 15 at 09:47am CEST
We're currently investigating this issue
Affected services